当前位置:首页 > 问答

量化短线选股模型

我来帮TA回答

通达信超短线选股公式哪个成功率最高

VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
J:(VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
K:EMA(J,1)COLORYELLOW;
D:EMA(J,3)COLORMAGENTA;

求个成功率高无未来的短线选股公式

闪牛分析:公式有很多,就是股市不一定会根据公式走;
1、几天内出现涨停
TS:=45;A:=5;
股价指示:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
行情启动:IF(CROSS(股价指示,A),100,0) AND C/REF(C,1)>1.00 AND C<28>=0.50;
2、15天内先死叉一次,今天金叉
S1:=IF(CODELIKE('300'),0,1);
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
S4:=DYNAINFO(4)>0;{去除停牌OR}
XG: S1 AND S2 AND S3 AND S4 AND C>0
AND RANGE(CAPITAL/100,3000,110000)
AND DYNAINFO(17)>=2.00{量比 }AND C<22
AND BETWEEN(V/CAPITAL*100, 2.3,30) AND
COUNT(CROSS(MA(C,10),MA(C,5)),15)=1 AND CROSS(MA(C,5),MA(C,10));
3、低位金叉选股
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;
4、二次金叉选股
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIFF,DEA) AND DEA<0;
5、三线粘合
M:=1;
M5:=MA(CLOSE,5);
M10:=MA(CLOSE,10);
M20:=MA(CLOSE,20);
K1:=MAX(MAX(M5,M10),MAX(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=MAX(M5,MAX(M10,M20))/MIN(M5,MIN(M10,M20))<1+0.03*M;
A1:=(K1/K2-1)<0.005;
A2:=(K1/K2-1)<0.005;
A3:=V>REF(V,1)*1.5 AND V>MA(V,5);
XG:A AND A1 AND A2 AND A3 AND C>O AND V> REF(V,1) AND CAPITAL<=300000000;
6、选强势股
{SJXXG四均线选股}
MA3:=MA(C,3);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
V0:=MA(C,3)>REF(MA(C,3),1) AND MA(C,5)>REF(MA(C,5),1) AND C>MA(C,3)
AND MA(C,3)>MA(C,5) ; {均线C,MA3,MA5多头排列并向上;}
角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
选股MA20:IF(角度MA3>45 AND 角度MA5>45 AND 角度MA10>60 AND 角度MA20>45 AND MA(C,250)>REF(MA(C,250),1),
1,0),COLOR00FF00;
7、捕抓涨停选股公式
A1:=REF(C,2)>REF(C,3)*1.095 AND REF(C,2)=REF(H,2);
A2:=REF(C,1)<REF(O,1)*1.005 AND REF(C,2)=REF(H,2);
A3:=C>REF(C,2) AND C>REF(H,1) AND C>=REF(C,1)*1.095 AND C=H;
双响炮:A1 AND A2 AND A3;
8、波浪式推进形态选股公式
均5:=MA(C,5);
均10:=MA(C,10);
均60:=MA(C,60);
均120:=MA(C,120);
角度5:=ATAN((均5/REF(均5,1)-1)*100)*180/3.1416;
角度10:=ATAN((均10/REF(均10,1)-1)*100)*180/3.1416;
角度60:=ATAN((均60/REF(均60,1)-1)*100)*180/3.1416;
角度120:=ATAN((均120/REF(均120,1)-1)*100)*180/3.1416;
A1:=MACD.DIF;
A2:=MACD.DEA;
量比:=VOL/MA(VOL,5);
均5>均10 AND 均10>均60 AND 均60>均120 AND 角度5>0 AND 角度10>0 AND 角度60>0 AND 角度120>0 AND CROSS(C,均5) AND 量比>2 AND A1>0 AND A2>0 AND A1>A2;
9底部黑马选股公式
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
AAA:=MA(BIAS,6);
BBB:=CROSS(BIAS,AAA) AND AAA<-9;
VAR13:=SMA(((LLV(CLOSE,60) - CLOSE) / (HHV(CLOSE,60) - LLV(CLOSE,60))),5,1);
AAAA:=((10/VAR13)-10)/5<-50;
VAR10:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
BB:=VAR10<-9> REF(VAR10,1);
超跌线:= MA(EMA(CLOSE,34)*0.82,5);
重超跌线:= MA(EMA(CLOSE,34)*0.75,5);
超跌89:=CROSS(C,超跌线);
马上有钱赚:BBB AND AAAA AND BB AND 超跌89;
10台阶黑马选股公式
参数: N 最小5.00 最大60.00 缺省20.00
N1 最小5.00 最大30.00 缺省10.00
均5:=MA(C,5);
均10:=MA(C,10);
均60:=MA(C,60);
均120:=MA(C,120);
角度5:=ATAN((均5/REF(均5,1)-1)*100)*180/3.1416;
角度10:=ATAN((均10/REF(均10,1)-1)*100)*180/3.1416;
角度60:=ATAN((均60/REF(均60,1)-1)*100)*180/3.1416;
角度120:=ATAN((均120/REF(均120,1)-1)*100)*180/3.1416;
A1:=MACD.DIF;
A2:=MACD.DEA;
量比:=VOL/MA(VOL,5);
S1:=CLOSE > 均5 AND 均5>均10 AND 均10>均60 AND 均60>均120 AND 角度5>0 AND 角度10>0 AND 角度60>0 AND 角度120>0 AND CROSS(C,均5) AND 量比>2 AND A1>0 AND A2>0 AND A1>A2;
S2:=REF(((HHV(HIGH,N)-LLV(LOW,N))/LLV(LOW,N)),1)<=(N1/100)
AND CLOSE>=REF(HHV(HIGH,N),1) AND BARSCOUNT(CLOSE)>N;
SG:S1 AND S2;

求一套简单好用的超短线选股公式准确率80%以上就行了!

我觉得这个问题比较有趣。

用选股器选短线股

那是骗人的

如何理解量化选股和量化择时之间的关系

所谓量化投资,就是通过定量或统计的方法,不断地从历史数据中挖掘有效的规律并在投资行为中加以利用,甚至通过计算机程序自动执行下单的动作。也就是说,量化投资方法是靠“概率”取胜,其最鲜明的特征就是可定量化描述的模型、规律或策略。
对于股票市场,量化投资主要包括量化选股、量化择时、算法交易、股票组合配置、资金或仓位管理、风险控制等。我们这里重点聊一聊量化选股和择时策略,其中前者解决哪些股票值得关注或持有,后者解决何时买入或卖出这些股票,以期在可承受的风险程度下,获得尽可能多的收益。
第一阶段:选股
选股的目标是从市场上所有可交易的股票中,筛选出适合自己投资风格的、具有一定安全边际的股票候选集合,通常称为“股票池”,并可根据自己的操作周期或市场行情变化,不定时地调整该股票池,作为下一阶段择时或调仓的基础。
量化选股的依据可以是基本面,也可以是技术面,或二者的结合。常用的量化选股模型举例如下:
1多因子模型
多因子模型:采用一系列的“因子”作为选股标准,满足这些因子的股票将作为候选放入股票池,否则将被移出股票池。这些因子可以是一些基本面指标,如 PB、PE、EPS 增长率等,也可以是一些技术面指标,如动量、换手率、波动率等,或者是其它指标,如预期收益增长、分析师一致预期变化、宏观经济变量等。多因子模型相对来说比较稳定,因为在不同市场条件下,总有一些因子会发生作用。
2板块轮动模型
板块轮动模型:一种被称作风格轮动,它是根据市场风格特征进行投资,比如有时市场偏好中小盘股,有时偏好大盘股,如果在风格转换的初期介入,则可以获得较大的超额收益;另一种被称作行业轮动,即由于经济周期的原因,总有一些行业先启动行情,另有一些(比如处于产业链上下游的)行业会跟随。在经济周期过程中,依次对这些轮动的行业进行配置,比单纯的买入持有策略有更好的效果。
3一致性预期模型
一致性预期模型:指市场上的投资者可能会对某些信息产生一致的看法,比如大多数分析师看好某一只股票,可能这个股票在未来一段时间会上涨;如果大多数分析师看空某一只股票,可能这个股票在未来一段时间会下跌。一致性预期策略就是利用大多数分析师的看法来进行股票的买入卖出操作。
与此类似的思路还有基于股吧、论坛、新闻媒体等对特定股票提及的舆情热度或偏正面/负面的消息等作为依据。还有一种思路是反向操作,回避羊群效应(物极必反),避免在市场狂热时落入主力资金出货的陷阱。
4资金流模型
资金流模型:其基本思想是根据主力资金的流向来判断股票的涨跌,如果资金持续流入,则股票应该会上涨,如果资金持续流出,则股票应该下跌。所以可将资金流入流出情况编制成指标,利用该指标来预测未来一段时间内股票的涨跌情况,作为选股依据。
第二阶段:择时
择时的目标是确定股票的具体买卖时机,其依据主要是技术面。取决于投资周期或风格(例如中长线、短线,或超短线),择时策略可以从比较粗略的对股票价位相对高低位置的判断,到依据更精确的技术指标或事件消息等作为信号来触发交易动作。
一般来说,择时动作的产生可以基于日K线(或周K线),也可以基于日内的小时或分钟级别K线,甚至tick级的分时图等。具体的量化择时策略可以分为如下几种:
1趋势跟踪型
趋势跟踪型策略适用于单边上升或单边下降(如果可做空的话)的行情——当大盘或个股出现一定程度的上涨和一定程度的下跌,则认为价格走势会进一步上涨或下跌而做出相应操作(买入->持有->加仓->继续持有->卖出)。
2高抛低吸型
高抛低吸型:高抛低吸型策略适用于震荡行情——当价格走势在一定范围的交易区间(箱形整理)或价格通道(平行上升或下降通道)的上下轨之间波动时,反复地在下轨附近买入,在上轨附近卖出,赚取波段差价利润(下轨买入->上轨卖出->下轨买入->上轨卖出->…)。
3横盘突破型
横盘突破型:价格走势可能在一定区间范围内长时间震荡,总有一天或某一时刻走出该区间,或者向上突破价格上轨(如吸筹阶段结束开始拉升),或者向下突破价格下轨(如主力出货完毕,或向下一目标价位跌落以寻找有效支撑),此时行情走势变得明朗。
横盘突破型策略就是要抓住这一突破时机果断开多或开空,以期用最有利价位和最小风险入场,获得后续利润(空仓或持仓等待机会->突破上轨则买入或平空/突破下轨则卖出或做空)。
常见的趋势跟踪型策略有:短时和长时移动均线交叉策略,均线多头排列和空头排列入场出场策略,MACD的DIFF和DEA线交叉策略等。如下图所示:
常见的高抛低吸型策略一般通过震荡类技术指标,如KDJ、RSI、CCI等,来判断价格走势的超卖或超卖状态,或通过MACD红绿柱或量能指标与价格走势间的背离现象,来预测波动区间拐点的出现。如下图所示:
常见的横盘突破策略包括布林带上下轨突破、高低价通道突破、Hans-123、四周法则等。如下图所示:
必须要强调的是,趋势跟踪型策略和高抛低吸型策略适用于完全不同的市场行情阶段——如果在单边趋势中做高抛低吸,或是在震荡行情中做趋势跟踪,则可能会造成很大亏损。因此,对这二者的使用,最关键的是,第一要尽量准确地判断当前行情类型,第二是要时刻做好止损保护(和及时止盈)。
总结一下:
在疯牛秘籍和疯牛形态系列产品中,提供了大量对股市规律的揭示、以及基于这些规律制定的量化策略,例如基于各类公告事件、资金动向、技术指标等制定的策略和规律,以及次日机会、底部形态反转等对应的交易时机。
这些实时动态的策略可为投资者的选股和择时操作提供高效的、有价值的参考。

量化模型是什么意思?

量化模型,是把数理统计学应用于科学数据,以使数理统计学构造出来的模型得到经验上的支持,并获得数值结果。这种分析是基于理论与观察的并行发展,而理论与观测又通过适当的推断方法而得以联系。

一个完整的量化模型包括哪些?

近几年,量化投资在国内兴起,但在很多人眼里,量化投资仿佛是一个非常神秘的新事物。而实际上,量化投资的无非就是宽客通过计算机语言,将交易策略布置到一个量化系统中,然后进行回测和实战的过程。量化投资的本质还是投资者的智慧,只是实现过程中运用到计算机这一工具。

宽客们到底是如何系统的构建一个完整的量化模型的?可以肯定的是,宽客跟普通投资者一样,也在观察市场,产生一些普通投资者也会想到的想法,当宽客产生一些想法时,他们会通过计算机去验证他们的想法是否靠谱或者是能否带来收益。而作为普通投资者,实现想法往往是困难的,如同普通投资者在投资或炒股过程中,发现在15分钟K线图,上升趋势中股价跌破MA169后便会进入调整。普通投资者只是感觉,而宽客可以通过编写程序然后在市场的历史数据回测,验证这个想法是否靠谱。

一个简单的想法编写成简单的程序,这明显不能称作为量化模型,但这却是任何一个量化模型的来源,即人的想法。完整的量化模型应当包括:策略模型、风险模型、交易成本模型、投资组合构建模型、执行模型,如下图:

策略模型:策略模型可以说是整个量化模型最核心的部分,决定了整个量化模型的盈利能力。策略模型五花八门,归类划分为:理论驱动型和数据驱动型。数据驱动型的策略通过对数据的分析而揭开市场的面纱,说白了就是靠数据解释一切市场行为。理论驱动型策略通过理论去预测未来的市场行为,而其中的理论就是人们通过对市场的观察,然后给出符合经济学原理的解释。

理论驱动型的策略可以划分为两大类:基于价格数据的交易策略和基于基本面数据的交易策略。基于价格数据的交易策略有:趋势跟随型(动量策略)、均值回复策略、技术情绪策略。基于基本面数据的交易策略有:价值型、成长型、品质型。如下图:

1.趋势跟随型:标志性策略就是双均线策略,投资者认为在一定时间内市场通常是朝着同一方向变化的。说白了,就是看涨做涨。

2.均值回复型:标志性策略就是统计套利策略,投资者认为在一定时间内市场并非朝着同一方向变化的。说白了,就是超涨了卖,超跌了买。

3.技术情绪型:标志性策略就是情绪指标策略,投资者认为通过某些价格、成交量可以暗示对投资者对后续行情的情绪,随后进行相应操作。其中比较有意思是通过比较期权的认购量和认沽量,来判断投资者对后续行情的情绪。

4.价值型:价值型策略的基本理念是:收益率越高,价格越低。通俗的讲,买入被低估的证券,卖出被高估的证券。

5.成长型:成长型策略往往投资成长性公司,成长性公司是指较长一段时间内,具有持续挖掘未利用资源能力,不同程度地呈现整体扩张态势,未来发展预期良好的企业。通俗的讲,买入正在快速发展以及具有良好发展前景的公司股票。

6.品质型:品质型策略选择公司的标志就不一样,有杠杆比率、收入来源的多样性、管理水平、欺诈风险等等。

上述策略模型在实施过程中必须考虑选股范围、选股标准、投资期限、交易信号、仓位控制、止盈止损。一个策略模型应当包含的因素都不可少,不然会影响到整个策略模型,进而导致整个量化模型失败。

风险模型:风险模型对于一个量化模型来说,是不可缺少的,它能提高量化模型盈利的质量和稳定性。风险模型分为:内部风险和外部风险。内部风险有:数据错误,个股风险,市场风险等等。外部风险有:网络风险,技术风险,物理风险等。

1.数据错误:模型进行回测或者实盘交易的过程中,数据本身如果是错误的,那么交易最终的结果也是没有意义的,如果是实盘交易,那么后果也是不堪设想的。

2.市场风险:量化模型在实盘交易过程中,由于整个策略程序并不能完美的预测出未来市场的任何一个变化,当宽客发现市场环境出现巨大变化,导致与量化策略所适应的的环境不一致时,就需要进行量化策略的暂停。

3.个股风险:与市场风险对应的是个股风险,基于价格数据驱动的策略尤其需要堤防个股风险,当公司的基本面短时间内发生巨大变化时,但技术层面并未及时更新,导致量化模型买入垃圾股票。

4.外部风险:外部风险指的是量化模型在实施过程中的现实风险,比如计算机下单时,由于网络中断,计算机硬件损坏,打雷地震等,导致交易单并未传送到交易所,从而产生损失。

设置风险模型的意义就在于,当量化模型遇到上述风险时,宽客能够及时采取措施,进行人工干预或者预备计算机启动,尽可能的减少损失。

交易成本模型:策略模型在于盈利,风险模型在于规避损失,交易成本模型则在于控制成本,使得整个量化模型的盈利最大化。交易成本模型的基本理念是:策略模型在运行过程中发生的成本较为精确的计算出来,从交易成本可以判断出策略模型运行频率。

交易成本一般有:佣金与费用、滑点、市场冲击成本。通常计算交易成本的方法有:常值型交易成本,线性交易成本,分段型交易成本。在真实的交易环境中,由于市场冲击成本的存在,每次交易的成本都是不一样的,常值型和线性交易成本的缺陷非常明显,而分段型交易成本在实际操作过程中略微复杂,因此精确的计算出交易成本本身就是一项技术活。

投资组合构建模型:投资组合构建模型在于构建一个能创造最大盈利的投资组合。主要分为:基于规则的投资组合构建模型和基于优化的投资组合构建模型。基于规则的投资组合构建模型主要分三类:相等头寸加权,相等风险加权,信号驱动型加权。其中前两类分别保证了投资组合的每个个股头寸相等和所承担的风险相等。第三类根据信号强度来加权,投资组合中个股与策略模型设定的条件越接近则赋予的权重越大,这是合理决定头寸规模的最佳途径。

执行模型:执行模型是实施量化模型的最后一个环节,如果没有执行模型,那么整个量化模型并没有存在的意义。执行模型中订单执行算法是最关键的,其主要目的是,以尽可能低的价格,尽可能完整地完成想要交易的订单。具体的执行算法包括:采用何种订单类型,采用进取订单还是被动订单,采用大订单还是小订单。对于资金量比较小的宽客,执行模型往往是比较简单的,一旦出现信号,其所需成交量的并不需要太大。而对于资金量较大的宽客来说,执行模型是比较复杂的,需要根据实际情况来选择合适的下单方式。

以上就是量化模型的整个系统框架,其中任何一个部分都发挥至关重要的作用,因此一个完整的能盈利的量化模型是非常有价值的。